Moderator: Moderator Team


Postby bob73 » 31 Mar 2010 11:27

I have a 10 ft yucca (inherited from previous owners) in my front garden. It has been fairly healthy for 6 years until recently.
Last weekend, I pruned off the dead leaves and in doing so, noticed a lot of rust spots, dead and dried up ends and mould on the leaves that remain

:?: Can anyone help with information as to what could be the matter and how I could treat it.

I have done some research and come up with anthracnose as a potential fungus but cannot find a method for treatment

:cry: Please help - I don't want to have to replace it as we all quite like it!
Clean Hands
Posts: 2
Joined: 31 Mar 2010 11:22

Postby gardening_guru » 01 Apr 2010 14:59

Hello Bob,

If you and your Yucca live in the U.K.? I think your poorly Yucca is a bit poorly because of the winter we have just had and still seem to be having in some parts of the country.
Short, dark, cold, wet winter days are just the sort of conditions that a hardy Yucca will hate. Is the soil generally free draining, it must be quite good for it to have done well over the previous 6 years?
I think you have done the right thing by removing the dead and diseased leaves. Now I would just pray for a long run of dry, sunny days.
George aka The Gardening Guru
User avatar
Site Admin
Posts: 222
Joined: 29 Nov 2005 13:19
Location: Cambridgeshire, UK

Postby bob73 » 01 Apr 2010 15:15

I had a feeling the snow might have had a hand in it's demise but have fingers crossed that it can come through!

Thanks for the enlightenment though :?
Clean Hands
Posts: 2
Joined: 31 Mar 2010 11:22

Return to Trees

Who is online

Users browsing this forum: No registered users and 0 guests